Adam Bien's Weblog

Ping For Java EE 7 / Java SE 8 v0.0.2 Released

Ping v0.0.2 is released.

New features:

  1. Start (boot) time
  2. Current memory stats
  3. Operating System Info
  4. Migration to Java 8, Java EE 7 (and deletion of some superfluous code)

Download the 8kB WAR directly.

More features are in the pipeline. Stay tuned.

See you at Java EE Workshops at MUC Airport or on demand and in a location very near you: airhacks.io.


NEW workshop: Microservices with Java EE 7 and Java 8, January 26th, 2015, Airport Munich

A book about rethinking Java EE Patterns

Comments:

Does not work.
What am I doing wrong?
When deploying I get IndexOutOfBounds and when access via browser I get UnsatisfiedDependencyException for ServerWatch!

Exception while visiting WEB-INF/classes/com/airhacks/ping/boundary/PingsResource.class of size 3688
java.lang.ArrayIndexOutOfBoundsException

Information: visiting unvisited references
Information: visiting unvisited references
Information: visiting unvisited references
Information: visiting unvisited references
Information: EJB5181:Portable JNDI names for EJB ServerWatch: [java:global/ping/ServerWatch, java:global/ping/ServerWatch!com.airhacks.ping.control.ServerWatch]
Information: Registering the Jersey servlet application, named com.airhacks.ping.RESTConfiguration, at the servlet mapping /resources/*, with the Application class of the same name.
Information: Loading application [ping] at [/ping]
Information: Loading application ping done in 209 ms
Information: Initiating Jersey application, version Jersey: 2.0 2013-05-14 20:07:34...
Warnung: StandardWrapperValve[com.airhacks.ping.RESTConfiguration]: Servlet.service() for servlet com.airhacks.ping.RESTConfiguration threw exception
org.glassfish.hk2.api.UnsatisfiedDependencyException: There was no object available for injection at Injectee(requiredType=ServerWatch,parent=HealthResource,qualifiers={}),position=-1,optional=false,self=false,unqualified=null,1871818533)

Posted by Joerg on August 08, 2014 at 02:56 PM CEST #

@Joerg,

it should just work. Actually: I'm working with ping floyd right now.

Requirements:
- Java EE 7 (tested with GF v4 and WildFly), use the javaee6 branch for Java EE 6 servers.
- Java 8 (for floyd, ping should compile under Java 7 as well)

Does it fly? :-)

cheers,

adam

Posted by Adam Bien on August 10, 2014 at 03:38 AM CEST #

Post a Comment:
  • HTML Syntax: NOT allowed
realworldpatterns.com
...the last 150 posts
...the last 10 comments
License